SA2(B) Races, 1 Lap, Expert - New Records aren't showing up in updates.


    Print

Author Topic: SA2(B) Races, 1 Lap, Expert - New Records aren't showing up in updates.  (Read 3509 times)

0 Members and 1 Guest are viewing this topic.

Offline GerbilSoft

  • Architect of the Matrix
  • TSC Profile
  • linux firefox
  • Posts: 711
  • RickRotate'd.
    • View Profile
[2007/12/01 02:16 AM EST]

SA2(B) Races, 1 Lap, Expert - submitting a new record doesn't seem to cause the system to add said new record as an update.

See http://www.soniccenter.org/members/darkspinessonic/sonic_adventure_2_b/races/1_lap/expert

Offline GerbilSoft

  • Architect of the Matrix
  • TSC Profile
  • linux firefox
  • Posts: 711
  • RickRotate'd.
    • View Profile
Re: SA2(B) Races, 1 Lap, Expert - New Records aren't showing up in updates.
« Reply #1 on: December 03, 2007, 11:43:47 PM »
This bug just happened with SDM's new Sonic 3 CN2/Sonic Rings record: http://www.soniccenter.org/members/spindashmaster/sonic_3/rings/carnival_night_2/sonic

It seems that it's detecting a "previous" rank, so it's not marking it as a new record. I'm not sure what this is. I'll see if Rolken can take a look at it tomorrow.

More Info: Looking at SDM's stat sheet, it seems that the stat wasn't given a rank initially for some reason. This bug occurs occasionally, and I'm not sure why. That's probably what prevented the statistics processor from marking it as a new record.
« Last Edit: December 03, 2007, 11:54:28 PM by GerbilSoft »

Offline GerbilSoft

  • Architect of the Matrix
  • TSC Profile
  • linux firefox
  • Posts: 711
  • RickRotate'd.
    • View Profile
Re: SA2(B) Races, 1 Lap, Expert - New Records aren't showing up in updates.
« Reply #2 on: December 03, 2007, 11:56:16 PM »
ARGH, I know what happened. SDM submitted the same stat twice in a row without statistics processing in-between, since I had the crontab turned off temporarily while haxing the site. Since the stat was seen twice, the statistics processor decided to ignore it the second time. Same with Da1 / DarkspinesSonic.

This bug still needs to be fixed, though.
« Last Edit: December 04, 2007, 01:28:50 AM by GerbilSoft »

    Print
 

Hits: 672 | Hits This Month: 8 | DB Calls: 8 | Mem Usage: 6.65 MB | Time: 0.09s | Printable

The Sonic Center v3.9
Copyright 2003-2011 by The Sonic Center Team.